Hasbro Star Wars The Vintage Collection Amazon Slave I Fix - Just Screw It

By Adam Pawlus — Tuesday, August 13, 2013

After almost a year of waiting since it was teased at Celebration VI in Orlando last year, we finally started to get our Amazon exclusive The Vintage Collection jumbo Slave I vehicle. It's 20-inches long, almost 50% bigger than the previous releases of Boba's vehicle, and has more features than ever. One of these features is a rotating wings and a gravity-centered pilot's station inside the cockpit, and in the 2010 The Clone Wars Rise of Boba Fett Battle Pack it worked great. This new version needs some work - a bad spring prevents things from locking properly. Want to fix it? Go get a Phillips head screwdriver, an old clicky pen, and read on.



The issue here is that a spring is too strong for the mechanism to function properly. The 2013 version is much thicker, and the 2010 Slave I's spring is much thinner and more wiry. Oddly, the cheaper, seemingly inferior spring is the one that works correctly.


What's supposed to happen is this: in flight mode, you manually rotate the wings and it unlocks the cockpit station to rotate freely into position, keeping the pilot upright. What actually happens is this: you move the wings to unlock the cockpit, and while it rotates down freely the wings snap back into "landing" position, preventing you from ever actually achieving "flight mode." Thankfully, you've probably got all the tools you need to fix this.

1x Phillips head screwdriver
1x spring-loaded clicking ball-point pen (you'll be stealing its spring, so if it's out of ink, that's fine) OR 1x small spring from hardware store - I don't know which one to get, so I just broke open a pen
1x wire cutters or really good, ruinable scissors

Step 1: Open the Vehicle
Flip over the vehicle and unscrew the bottom panel - the entire bottom of the ship is loaded with screws, so don't lose them. The bottom panel will pop off easily, provided the bombs aren't in the way.


Step 2: Locate the Errant Mechanism
There's a small switch around the axle connecting the wings, located near the Carbonite storage slot. This mechanism is the problem - there are two more screws here housing a spring and a lever which locks the rotating cockpit section in place. Unscrew this, and remove (but do not lose) the spring. You may want the spring later.


Step 3: Replace the Spring
If you have the right size spring in your junk drawer, congratulations - use it, and everything will be fine. If you don't, you can cobble one together from a pen. Unscrew the pen and remove the spring. Cut the spring down to size - make sure it's longer than you think you need, because you can always cut it down, and you can't un-cut a metal spring. (Science won't allow it.) When it's down to a good size, install the spring and close up the compartment, replacing the switch, cover, and screws.


Step 4: Test the Mechanism
Plug in a wing and see what happens. If the wings rotate freely and the cockpit just floats around, it's possible you cut the spring too small or it's too loose. If you continue to have the same problem as before, cut the spring down a bit, stretch it out thinner (so there's less resistance) and try again. Don't cut off more than a few millimeters each time, because again, you can't grow the spring again. Repeat until it works good enough for your needs.

Step 5: Close the Vehicle
Replace the screws on the bottom panel, and pat yourself on the back. You used your tools to fix something. Today, my son, you are a man. Unless you're a lady, in which case... for the sake of argument, let's say you, too, are a man. Be proud.

Thanks for the tip, tried it

Thanks for the tip, tried it on mine and it worked a treat! :D


Thanks, Adam. Now all I need is a Slave I to fix. Sigh.

Also, I was wondering....

Adam, I was also wondering, are there any reports of the ship working correctly out of the box for anyone, or is this such a problem that everyone is experiencing it? I'm hoping there are some kind of odds that I won't have to do that with mine after it arrives.

I have heard people who were

I have heard people who were happy with how it performs out of the box, but it seems a lot of those people say things like "it works great, just force it until you hear a loud click" which is NOT how the 2010 version worked. The best thing I can say is to get it, try it, and if you're happy with how it works - hey, awesome! And if not, there's a mod you can do. And if you don't care either way, it looks awesome sitting on a shelf.